Klub Cytrynki
Francuskie.pl - Twoja codzienna
porcja aktualności na temat marki Citroen

Autor Wątek: MK1 2.0 HDI nie odpala  (Przeczytany 1464 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline Rafał Dumała

  • Przyspiesza
  • Wiadomości: 72
  • Skąd: Legionowo
  • Posiadany samochód: C5 2.0 HDI 2004
  • Zainteresowania: Elektronika, motoryzacja, IT
  • Miejscowość: Warszawa
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #25 dnia: Listopad 19, 2021, 16:54:06 »
Tak, dokładnie. Nie mam pojęcia co się stało dlatego jestem przygotowany na wszystko. Sprawdzałem dzisiaj odpalanie bez czujników. Błędy się pokazały, samochód nie odpalił. Z wydechu czuć że śmierdzi ale nie tak jak z diesla zapach jest trochę inny. Dodatkowo słychać piszczenie z okolic pompy WC - może to być łożysko alternatora albo sama pompa... Ona jest napędzana z paska rozrządu? Jeżeli tak to zdjeme jutro pasek osprzętu i sprawdzę rolki to co na nim jest oraz czy nadal będzie piszczę  przy odpalaniu. Co do samego napięcia akumulatora to spada bardzo nisko mimo że nadal kręci. Spróbuję podmienić akumulator na jakiś sprawny. Tak jakby co to wymiana pompy WC jest do wykonania przez amatora? Czy sa tam potrzebne jakieś magiczne narzędzia? Klucz dynamometryczny mam ale np. W 508 Hybrid4 był potrzebny specjalny klucz do napinacza paska osprzętu.

Offline Andrzej Gromotowicz

  • Przyspiesza
  • Wiadomości: 24
  • Skąd: Narewka podlaskie
  • Posiadany samochód: C5 MkII 1,6 HDi 2005r. +C5 MkI 2,0 HDi 2003r
  • Miejscowość: Narewka podlaskie
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #26 dnia: Listopad 19, 2021, 17:25:58 »
Witam. Aby silnik HDI odpalił musi osiągnąć minmum 200obr/min i150 bar ciśnienia na listwie, tak że akumulator, rozrusznik a być może połączenia masowe do sprawdzenia. Ze swojego doświadczenia dodam, że oczyszczenie masy spowodowało żwawsze kręcenie rozrusznika. Liczę, że ogłosisz rozwiązanie zagadki.

Offline Rafał Dumała

  • Przyspiesza
  • Wiadomości: 72
  • Skąd: Legionowo
  • Posiadany samochód: C5 2.0 HDI 2004
  • Zainteresowania: Elektronika, motoryzacja, IT
  • Miejscowość: Warszawa
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #27 dnia: Listopad 19, 2021, 18:01:16 »
coś może w tym być, masz na myśli jakiś konkretny przewód masowy? Czy wszystkie które znajdę pod maską?

Offline Sylwester Maciejczuk

  • Byle do przodu
  • *
  • Wiadomości: 336
  • Skąd: Radzymin k.Warszawy
  • Posiadany samochód: Była Xantia 2.0 CT Activa 96 jest Xantia 1.8 16V 98 C5 3.0 V 6 24 Carlsson 04 LPG
  • Zainteresowania: motoryzacja elektronika
  • Miejscowość: Radzymin k.Warszawy
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #28 dnia: Listopad 19, 2021, 20:16:38 »
Rafał może jest problem z czujnikiem uderzeniowym,jeśli u Ciebie jest, mam tylko schemat od Xsary gdzie jest i podaje jedno z napiec do ECU.
 
Nich się też wypowiedzą Koledzy czy jest i czy Lexia  widzi przerwę na nim.


Pozdrawiam.

Offline Bohdan Gonczaruk

  • Mistrz prostej
  • **
  • Wiadomości: 592
  • Skąd: Krakow
  • Posiadany samochód: C-5 HDi 2.0 136KM
  • Zainteresowania: ciekawe rzeczy
  • Miejscowość: Krakow
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #29 dnia: Listopad 19, 2021, 22:26:23 »
Pompa WC jest napędzana z paska rozrządu i nie wymaga ustawienia na znaki, bo ona daje tylko ciśnienie. Ogólnie rozrząd jest bardzo prosty, wszystko jest na klinach, rolka napinacza jest sztywna na mimośrodzie a do korekcji "fasolki" na kole wałka rozrządu. Do dobrego zablokowania wału trzeba odkręcić rozrusznik, bo pod nim jest otwór na blokadę, a do blokady wałka trzpień fi8 wkładany przez koło zębate wałka w otwór głowicy. Trzeba zwrócić uwagę na dobre napięcie paska, bo nie ma tu sprężyny  i wskażnika w napinaczu.   Jakie miałeś napięcie podczas rozruchu?

Offline Piotr Puścian

  • Kierowca bombowca
  • ****
  • Wiadomości: 6 135
  • Skąd: Sokołów Podlaski
  • Posiadany samochód: C5 FL 2.0 16V (RFJ) LPG + skrzynia 20MB06 + C-Nomade V2
  • Miejscowość: Sokołów Podlaski
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #30 dnia: Listopad 19, 2021, 22:43:28 »
Witam. Aby silnik HDI odpalił musi osiągnąć minmum 200obr/min i150 bar ciśnienia na listwie, tak że akumulator, rozrusznik a być może połączenia masowe do sprawdzenia. Ze swojego doświadczenia dodam, że oczyszczenie masy spowodowało żwawsze kręcenie rozrusznika. Liczę, że ogłosisz rozwiązanie zagadki.
Też mi się wydawało że właśnie 200 obrotów przynajmniej powinno być.

 Kolega wspominał że miał podłączony akumulator drugi na kablach rozruchowych... Jak z dwoma nie da rady zakręcić dobrze. To coś nie halo z rozrusznikiem... Lub właśnie przewodami masy lub zasilania.

Offline Rafał Dumała

  • Przyspiesza
  • Wiadomości: 72
  • Skąd: Legionowo
  • Posiadany samochód: C5 2.0 HDI 2004
  • Zainteresowania: Elektronika, motoryzacja, IT
  • Miejscowość: Warszawa
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #31 dnia: Listopad 19, 2021, 23:24:59 »
Z masą będzie problem. Zauważyłem że jak podłączałem akumulator drugi klemami minusem do karoserii lub bezpośrednio do akumulatora to była różnica napięcia o kilkanaście mV. Napięcie przy rozruchu na jednym akumulatorze spadało do 9V mimo to rozrusznik kręcił bez zauważalnej różnicy. Teraz akumulator się ładuje, jutro poodkręcam masy i przeczyszcze.

Offline Bohdan Gonczaruk

  • Mistrz prostej
  • **
  • Wiadomości: 592
  • Skąd: Krakow
  • Posiadany samochód: C-5 HDi 2.0 136KM
  • Zainteresowania: ciekawe rzeczy
  • Miejscowość: Krakow
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #32 dnia: Listopad 20, 2021, 00:16:33 »
9V to jest bardzo słabo... Pożycz od kogoś dobry aku, bo bo stary, nawet w pełni naładowany, nie jest w stanie wydać z siebie odpowiedniego prądu. No i oczywiście... podstawą elektryki są dobre styki ;D

Offline Rafał Dumała

  • Przyspiesza
  • Wiadomości: 72
  • Skąd: Legionowo
  • Posiadany samochód: C5 2.0 HDI 2004
  • Zainteresowania: Elektronika, motoryzacja, IT
  • Miejscowość: Warszawa
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #33 dnia: Listopad 20, 2021, 09:41:07 »
Jadę do zakładu regeneracji rozruszników. Zobaczymy co powiedzą, dzisiaj po 10sek kręcenia kręcił jakby nie miał siły i poleciał z niego dym. Może ma już dosyć. Dam znać ;)

Offline Piotr Puścian

  • Kierowca bombowca
  • ****
  • Wiadomości: 6 135
  • Skąd: Sokołów Podlaski
  • Posiadany samochód: C5 FL 2.0 16V (RFJ) LPG + skrzynia 20MB06 + C-Nomade V2
  • Miejscowość: Sokołów Podlaski
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #34 dnia: Listopad 20, 2021, 11:47:29 »
Jadę do zakładu regeneracji rozruszników. Zobaczymy co powiedzą, dzisiaj po 10sek kręcenia kręcił jakby nie miał siły i poleciał z niego dym. Może ma już dosyć. Dam znać ;)
Czyli dobrze czułem.  ;) Słaby rozrusznik daje efekty jak by akumulator był do wymiany. Od razu to widać jak podepnie się drugi akumulator na kable.

 Pewnie głównego problemu to nie załatwi...

Offline Rafał Dumała

  • Przyspiesza
  • Wiadomości: 72
  • Skąd: Legionowo
  • Posiadany samochód: C5 2.0 HDI 2004
  • Zainteresowania: Elektronika, motoryzacja, IT
  • Miejscowość: Warszawa
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #35 dnia: Listopad 20, 2021, 14:04:50 »
Piotr masz rację, dzisiaj się trochę pobawiłem i tak:

1. Nowy rozrusznik kreci 250-300obr na minutę.
2. Zmieniłem 4 świece i moduł. Błąd zniknął.
3. Ciśnienie sprężania 25bar, idealnie równo na każdym.
4. Przelewy, szczerze nie wiem jak powinny się zachować. Więc opiszę jak to wygląda:

a) paliwo dochodzi bo się pojawia na przelewach.
b) 2-gi cylinder napełnia się najszybciej. Ale różnica to jakieś 1/4 szybciej niż reszta po 15sek kręcenia.
c) leje się z przewodu, który był wpięty w przelewy. Powinno? On jest połączony z powrotem paliwa.

Jedyne czego nie wiem to czy wtryski dostają sygnał otwarcia, miernik cęgowy kupię ale pewnie dojdzie w tygodniu.

Co ciekawe po próbie odpalania śmierdzi z wydechu ale nie tak jak normalnie specyficznie z diesla tylko zapach jest bardziej gryzący i chemiczny.

Czy RHZ z 2004 roku ma FAP?

Błędów żadnych, jedyne co znalazłem to niepoprawny sygnał obrotów silnika na zegarach ale to może być wina słabego akumulatora. Lexia pokazuje obroty, tak samo pokazuje że wałek z wałem są zsynchronizowane. Brak plusa stałego na wyświetlaczu tym dodatkowym małym na desce po środku - ten nad radiem. I brak komunikacji z radiem. Błędy nie związane a nadal nie odpala. Jak kręcę rozrusznikiem to telepie całą budą, pewnie poduszki będą do wymiany ale to też nie związane z odpalaniem.

Dodam tylko że demontaż i montaż rozrusznika w tym silniku to czysta przyjemność - kiedyś chciałem wyjąć z opla i po 3h leżenia na glebie odpuściłem. Tu 15 minut i rozrusznik w ręku :)

Drugi akumulator który podłączałem odpala bez problemu Mercedesa 3.2 CDI 6 cylindrów więc rozrusznik musiał mieć problem i ciągnął za dużo prądu. Teraz podczas rozruchu napięcie spada lekko poniżej 12V.

Macie może jeszcze jakiś pomysł?
« Ostatnia zmiana: Listopad 20, 2021, 14:22:41 wysłana przez Rafał Dumała »

Offline Piotr Puścian

  • Kierowca bombowca
  • ****
  • Wiadomości: 6 135
  • Skąd: Sokołów Podlaski
  • Posiadany samochód: C5 FL 2.0 16V (RFJ) LPG + skrzynia 20MB06 + C-Nomade V2
  • Miejscowość: Sokołów Podlaski
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #36 dnia: Listopad 20, 2021, 14:15:31 »
25 bar sprężania to taka dolna granica dla diessla raczej. Nie mniej powinien załapać.

Czy ma FAP? Trzeba by sprawdzić po VIN. Były z i bez.

 Osobiście spróbowałbym zaślepić EGR i jeśli tam jest, wymusić aby miał otwarta przepustnice... Ale chyba nie tędy droga. Na odległość już nie mam za bardzo pomysłòw.

Offline Rafał Dumała

  • Przyspiesza
  • Wiadomości: 72
  • Skąd: Legionowo
  • Posiadany samochód: C5 2.0 HDI 2004
  • Zainteresowania: Elektronika, motoryzacja, IT
  • Miejscowość: Warszawa
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #37 dnia: Listopad 20, 2021, 14:19:30 »
Znalazłem gdzieś w necie informacje że sprężanie powinno być od 25-30 nominalnie a 18 to minimum poniżej którego nie odpali. Co do EGR to nie powinno być tak że odpali a co najwyżej nie będzie miał mocy i będzie słabo jeździł?

Offline Piotr Puścian

  • Kierowca bombowca
  • ****
  • Wiadomości: 6 135
  • Skąd: Sokołów Podlaski
  • Posiadany samochód: C5 FL 2.0 16V (RFJ) LPG + skrzynia 20MB06 + C-Nomade V2
  • Miejscowość: Sokołów Podlaski
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #38 dnia: Listopad 20, 2021, 14:37:15 »
Jak EGR otwarty będzie też duży problem z rozruchem. Tam jeszcze jest na podciśnienie? Może wężyk...

 Co do ciśnienia... Znajomy miał 2.0 HDi RHR-a który miał po 22 bary, latem jeździł nim. Zimą Clio 1.2  :D Rozpalić tego diessla zimą to była masakra. Problemy zaczynały się już w okolicy 10 stopni Celsjusza.

Offline Rafał Dumała

  • Przyspiesza
  • Wiadomości: 72
  • Skąd: Legionowo
  • Posiadany samochód: C5 2.0 HDI 2004
  • Zainteresowania: Elektronika, motoryzacja, IT
  • Miejscowość: Warszawa
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #39 dnia: Listopad 20, 2021, 15:05:46 »
Sprawdzałem jeszcze z plakiem, jak zdjąłem rurę od intercoolera i psiknąłem to chodził normalnie, lekkie psiknięcie i podnosił obroty, jak przestałem to gasł. Wygląda na to że ewidentnie nie dostaje paliwa. Albo wtryski nie dostają sygnału albo dostają ale nie działają, ewentualnie ciśnienie paliwa za małe i nie dają rady się otworzyć. Ciśnienie na listwie wg Lexii jest ok. Sterownik nie jest zablokowany i nie ma żadnych błędów. Tak samo jakby rozrząd był problemem to na plaka by nie chodził a na plaku pracuje normalnie. Nawet ładnie trzyma obroty jałowe ;-) Trochę to dziwne myślałem że z plakiem psikne, odpali, zgaśnie i tak dalej a on chwilę chodzi i jak doleje to podniesie obroty na ok 1700 i spada na 900 chodzi chwilę na 900 i przygasa. Może EGR rzeczywiście jest cały czas otwarty. Tylko czy efekt byłby aż tak "drastyczny" że w ogóle nie odpala.

Offline Bohdan Gonczaruk

  • Mistrz prostej
  • **
  • Wiadomości: 592
  • Skąd: Krakow
  • Posiadany samochód: C-5 HDi 2.0 136KM
  • Zainteresowania: ciekawe rzeczy
  • Miejscowość: Krakow
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #40 dnia: Listopad 20, 2021, 15:55:40 »
Z przelewów raczej nie powinno się lać przy rozruchu. Odłączyłeś przelewy od reszty układu?

Offline Rafał Dumała

  • Przyspiesza
  • Wiadomości: 72
  • Skąd: Legionowo
  • Posiadany samochód: C5 2.0 HDI 2004
  • Zainteresowania: Elektronika, motoryzacja, IT
  • Miejscowość: Warszawa
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #41 dnia: Listopad 20, 2021, 16:02:23 »
No tak ale listwa jest tylko "akumulatorem" ciśnienia paliwa takim jakby wiadrem/kondensatorem co oznacza że nie puszcza paliwa na wtryski tylko utrzymuje cały czas ciśnienie napompowane przez pompę, czyli jak już to nieszczelne byłyby wtryski albo zawór, ktory upuszcza/zbija ciśnienie. Patrzyłem na wskazania czujnika ciśnienia i spada dość szybko, pompa ładuje do ok 400bar i po 5 sek od zaprzestania kręcenia rozrusznikiem jest znow 8bar. Przy czym gdyby zawór nie trzymał to by rozerwało przelewy/ przewody paliwowe bo ciśnienie lecialoby bezpośrednio do nich.

Offline Bohdan Gonczaruk

  • Mistrz prostej
  • **
  • Wiadomości: 592
  • Skąd: Krakow
  • Posiadany samochód: C-5 HDi 2.0 136KM
  • Zainteresowania: ciekawe rzeczy
  • Miejscowość: Krakow
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #42 dnia: Listopad 20, 2021, 16:07:31 »
Paliwo z przelewów wraca swobodnie do zbiornika, więc nie może się sprężyć... Często jeden wtrysk może powodować problemy z odpaleniem w CR.

Offline Rafał Dumała

  • Przyspiesza
  • Wiadomości: 72
  • Skąd: Legionowo
  • Posiadany samochód: C5 2.0 HDI 2004
  • Zainteresowania: Elektronika, motoryzacja, IT
  • Miejscowość: Warszawa
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #43 dnia: Listopad 20, 2021, 16:47:34 »
Jeżeli jest spora szansa że to to wtryski to mogę kupić komplet ;) Używki w cholera wie jakim stanie są po 50pln a za 180 są z wynikami pomiarów. Trzeba je jakoś programować? Z tego co pamiętam w niektórych przypadkach podaje się w sterowniki jakieś dane wtryskiwacza.

Offline Piotr Puścian

  • Kierowca bombowca
  • ****
  • Wiadomości: 6 135
  • Skąd: Sokołów Podlaski
  • Posiadany samochód: C5 FL 2.0 16V (RFJ) LPG + skrzynia 20MB06 + C-Nomade V2
  • Miejscowość: Sokołów Podlaski
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #44 dnia: Listopad 20, 2021, 16:54:38 »
Bez programowania zmienionych wtryskiwaczy odpali kazdy... Będzie może trochę "kulawy" ale zapali. Chyba nawet w tym silniku nie ma opcji programowania.

 Nie mniej wątpię że nie odpala przez wtryski. Byłby to dziwny przypadek. Nawet przy problemach z wtryskami przy próbie z Plakiem powinien zapalić.

 Po zmianie rozrusznika Lexia widzi jakieś parametry otwarcia wtryskiwaczy?

Offline Bohdan Gonczaruk

  • Mistrz prostej
  • **
  • Wiadomości: 592
  • Skąd: Krakow
  • Posiadany samochód: C-5 HDi 2.0 136KM
  • Zainteresowania: ciekawe rzeczy
  • Miejscowość: Krakow
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #45 dnia: Listopad 20, 2021, 16:57:34 »
Tak, trzeba je wpisywać, ale bez wpisania też powinien odpalić. Musisz jednak jakoś sprawdzić czy wtryski dostają napięcie. Co do miernika cęgowego, jak chcesz mieć z niego pożytek, to powinien być z możliwością pomiaru prądu stałego.

Offline Piotr Puścian

  • Kierowca bombowca
  • ****
  • Wiadomości: 6 135
  • Skąd: Sokołów Podlaski
  • Posiadany samochód: C5 FL 2.0 16V (RFJ) LPG + skrzynia 20MB06 + C-Nomade V2
  • Miejscowość: Sokołów Podlaski
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #46 dnia: Listopad 20, 2021, 17:05:08 »
Tak, trzeba je wpisywać, ale bez wpisania też powinien odpalić. Musisz jednak jakoś sprawdzić czy wtryski dostają napięcie. Co do miernika cęgowego, jak chcesz mieć z niego pożytek, to powinien być z możliwością pomiaru prądu stałego.
Oj chyba w tym nie ma nawet opcji wpisywania... Chociaż to zależy od obecności FAP. Zwykle jak nie ma FAP nie ma opcji wpisywania. Jak jest FAP jest i opcja.

 To chyba oczywiste że miernik do auta musi mieć możliwość pomiarów na prądzie stałym. Kiedyś taką zabawkę kupiłem za 300zł do 600A mierzy. Niedawno kolega kupił za 150zł ale skalę ma nieco mniejszą. Taki miernik sporo ułatwia w zabawach elektrycznych przy aucie. Nawet prąd pobierany przez rozrusznik można zmierzyć. (Testowałem na silniku 1.4 OHV dwa oleje. 5W50 i 10W40. Sam olej zmieniał pobór prądu rozruchu o 100A latem na zimnym silniku.)

Offline Bohdan Gonczaruk

  • Mistrz prostej
  • **
  • Wiadomości: 592
  • Skąd: Krakow
  • Posiadany samochód: C-5 HDi 2.0 136KM
  • Zainteresowania: ciekawe rzeczy
  • Miejscowość: Krakow
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #47 dnia: Listopad 20, 2021, 17:16:52 »
To chyba zależy której firmy są wtryski. Ja miałem MK1 z 2001 i był bosch, ale chyba w 2002 wprowadzili też siemensa. Ja mam miernik z automatyczną zmianą zakresów i np. prądu rozruchu nim nie zmierzysz, bo nie zdąży się przestawić.... ;D

Offline Rafał Dumała

  • Przyspiesza
  • Wiadomości: 72
  • Skąd: Legionowo
  • Posiadany samochód: C5 2.0 HDI 2004
  • Zainteresowania: Elektronika, motoryzacja, IT
  • Miejscowość: Warszawa
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #48 dnia: Listopad 20, 2021, 17:17:14 »
No właśnie tu mam problem, nie wiem na co patrzeć, znalazłem "wydatek wtrysku końcowego" ale on jest obok parametrów FAP więc raczej jest do wypalania. Za to wyprzedzenie wtrysku się zmienia. Tak jakby było wysterowane. Wyprzedzenie wtrysku głównego 3stopnie a wstępnego 17 stopni. Ciśnienie paliwa 300bar. Dodatkowo zauważyłem że Wyłączenie 3-go tłoka (jeżeli jest) jest zawsze na tak

Wtryski mam Bosch

Offline Piotr Puścian

  • Kierowca bombowca
  • ****
  • Wiadomości: 6 135
  • Skąd: Sokołów Podlaski
  • Posiadany samochód: C5 FL 2.0 16V (RFJ) LPG + skrzynia 20MB06 + C-Nomade V2
  • Miejscowość: Sokołów Podlaski
Odp: MK1 2.0 HDI nie odpala
« Odpowiedź #49 dnia: Listopad 20, 2021, 17:24:36 »
To chyba zależy której firmy są wtryski. Ja miałem MK1 z 2001 i był bosch, ale chyba w 2002 wprowadzili też siemensa. Ja mam miernik z automatyczną zmianą zakresów i np. prądu rozruchu nim nie zmierzysz, bo nie zdąży się przestawić.... ;D
Właśnie zmiana wtryskiwaczy nastąpiła chyba przez FAP-a.

 Używam UNI-T UT204+ teraz widzę trochę cena spadła. Ale mam już go kilka lat... W sumie nie żałuję zakupu. Tylko do pomiarów napięcia nadal wolę używać starego klasycznego multimetru od UNI-T-a.

 Z ciekawostek trafiłem na RHR-a fabrycznie bez FAP w polifcie. Nie miał opcji kodowania wtryskiwaczy.

 Wracając do tematu. W czym leży przyczyna będzie ciężko zgadnąć na odległość. Tu już chyba właściciel musi podjąć ryzyko i coś wymienić w ciemno.